*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ghp-import / ghp-import-0.4.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Copy your docs directly to the gh-pages branch"
10 HOMEPAGE="https://github.com/davisp/ghp-import"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="tumbolia"
14 SLOT="0"
15 KEYWORDS="amd64"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND=""
20
21 python_prepare_all() {
22         ebegin 'patching setup.py'
23         sed \
24                 -e '4ifrom codecs import open\n' \
25                 -e '/LONG_DESC/s/))/), encoding = "utf-8")/' \
26                 -i setup.py
27         STATUS=${?}
28         eend ${STATUS}
29         [[ ${STATUS} -gt 0 ]] && die
30
31         distutils-r1_python_prepare_all
32 }