*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / fuzzywuzzy / fuzzywuzzy-0.17.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Fuzzy string matching in python"
11 HOMEPAGE="https://github.com/seatgeek/fuzzywuzzy"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 KEYWORDS="~amd64 ~x86"
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE="test"
18
19 RESTRICT="!test? ( test )"
20
21 DEPEND="test? ( dev-python/pycodestyle[${PYTHON_USEDEP}] )"
22 RDEPEND="${PYTHON_DEPS}
23         dev-python/python-levenshtein[${PYTHON_USEDEP}]"
24
25 python_test() {
26         "${PYTHON}" test_fuzzywuzzy.py || die "tests failed under ${EPYTHON}"
27 }