090175b790773c0f44579cae1909162779f10ed7
[gentoo.git] / dev-python / functools32 / functools32-3.2.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=no
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Backport of the functools module from Python 3"
12 HOMEPAGE="https://pypi.org/project/functools32/ https://github.com/MiCHiLU/python-functools32"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}-2.tar.gz"
14
15 SLOT="0"
16 LICENSE="PSF-2.4"
17 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
18 IUSE=""
19
20 S="${WORKDIR}"/${P}-2
21
22 python_test() {
23         "${PYTHON}" test_functools32.py || die
24 }