*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / fs / fs-0.5.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="Filesystem abstraction layer"
11 HOMEPAGE="
12         https://pypi.org/project/fs/
13         https://docs.pyfilesystem.org
14         https://www.willmcgugan.com/tag/fs/"
15 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
20 IUSE="test"
21
22 RDEPEND="
23         dev-python/dexml[${PYTHON_USEDEP}]
24         dev-python/six[${PYTHON_USEDEP}]
25 "
26 DEPEND="${RDEPEND}
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 dev-python/mako[${PYTHON_USEDEP}]
30                 dev-python/nose[${PYTHON_USEDEP}]
31         )"
32
33 # Tries to access FUSE
34 RESTRICT=test
35
36 python_test() {
37         nosetests --verbose || die
38 }
39
40 pkg_postinst() {
41         optfeature "S3 support" dev-python/boto
42         optfeature "SFTP support" dev-python/paramiko
43         optfeature "Browser support" dev-python/wxpython
44 }