*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / fqdn / fqdn-1.2.0.ebuild
1 # Copyright 2018-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
11 HOMEPAGE="https://github.com/guyhughes/fqdn"
12 SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MPL-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND="dev-python/cached-property[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}"
23
24 distutils_enable_tests unittest