*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / flexx / flexx-0.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Pure Python toolkit for creating GUI's using web technology"
11 HOMEPAGE="
12         https://flexx.readthedocs.org
13         https://github.com/zoofio/flexx
14         https://pypi.org/project/flexx/"
15 SRC_URI="https://github.com/zoofIO//${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
20
21 #IUSE="doc test" broken tests
22 IUSE=""
23 RDEPEND="www-servers/tornado[${PYTHON_USEDEP}]"
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"