*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / flexmock / flexmock-0.10.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Testing library to create mocks, stubs and fakes"
11 HOMEPAGE="http://flexmock.readthedocs.org/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         test? (
22                 dev-python/pytest[${PYTHON_USEDEP}]
23         )
24         "
25 RDEPEND=""
26
27 python_install_all() {
28         distutils-r1_python_install_all
29         dodoc -r  docs
30 }
31
32 python_test() {
33         pytest -vv tests || die "pytest failed"
34 }