*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / flask-themes / flask-themes-0.1.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 MY_PN="Flask-Themes"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="Infrastructure for theming support in Flask applications"
13 HOMEPAGE="https://pythonhosted.org/Flask-Themes/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE=""
20 # suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
21 RESTRICT="test"
22
23 RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]"
26
27 S="${WORKDIR}/${MY_P}"
28
29 PATCHES=( "${FILESDIR}"/fixtests.patch )