*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / flask-sphinx-themes / flask-sphinx-themes-1.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 MY_PN="Flask-Sphinx-Themes"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="Sphinx Themes for Flask related projects and Flask itself"
13 HOMEPAGE="https://github.com/pallets/flask-sphinx-themes https://pypi.org/project/Flask-Sphinx-Themes/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="amd64 x86"
19 IUSE=""
20
21 RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]"
24
25 PATCHES=( "${FILESDIR}/${P}-python2-encoding-kw.patch" )
26
27 S="${WORKDIR}/${MY_P}"