*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / flake8-import-order / flake8-import-order-0.18.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Flake8 plugin that checks import order against various Python Style Guides"
11 HOMEPAGE="https://github.com/PyCQA/flake8-import-order"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/pycodestyle[${PYTHON_USEDEP}]
22         virtual/python-enum34[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}
24         test? (
25                 dev-python/pytest[${PYTHON_USEDEP}]
26                 dev-python/flake8[${PYTHON_USEDEP}]
27                 dev-python/pycodestyle[${PYTHON_USEDEP}]
28                 dev-python/pylama[${PYTHON_USEDEP}]
29         )"
30
31 python_test() {
32         py.test -v tests || die "tests failed with ${EPYTHON}"
33 }