*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / extras / extras-1.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 pypy pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Useful extra bits for Python that should be in the standard library"
11 HOMEPAGE="https://github.com/testing-cabal/extras/ https://pypi.org/project/extras/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
23 RDEPEND=""
24
25 python_test() {
26         "${PYTHON}" ${PN}/tests/test_extras.py || die
27 }