*/*: Bump copyright on files touched this year
[gentoo.git] / dev-python / egg-python / egg-python-2.25.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 # We don't support the egg.recent bindings that are also provided - they are
7 # deprecated, have deps we don't really want and there are no users in-tree.
8 GNOME_ORG_MODULE="gnome-python-extras"
9 G_PY_BINDINGS="eggtray"
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit autotools eutils gnome-python-common-r1
13
14 DESCRIPTION="EggTrayIcon bindings for Python"
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~alpha amd64 ~arm ia64 ppc ppc64 sparc x86"
18 IUSE="examples"
19
20 RDEPEND=">=dev-python/libbonobo-python-2.22.1[${PYTHON_USEDEP}]
21         >=dev-python/libgnome-python-2.22.1[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         gnome-base/gnome-common"
25 # eautoreconf needs gnome-base/gnome-common
26
27 EXAMPLES=( examples/egg/trayicon.py )
28
29 src_prepare() {
30         epatch "${FILESDIR}/${P}-python-libs.patch" #344231
31         sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
32         eautoreconf
33         gnome-python-common-r1_src_prepare
34 }