*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / duecredit / duecredit-0.7.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Publications (and donations) tracer"
10 HOMEPAGE="https://github.com/duecredit/duecredit"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
20         dev-python/requests[${PYTHON_USEDEP}]
21         dev-python/six[${PYTHON_USEDEP}]"
22 BDEPEND="
23         ${RDEPEND}"