*/*: Bump copyright on files touched this year
[gentoo.git] / dev-python / drf-yasg / drf-yasg-1.17.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 python3_7 )
7 inherit distutils-r1
8
9 DESCRIPTION="Automated generation of Swagger/OpenAPI 2.0 schemas from Django Rest framework"
10 HOMEPAGE="https://github.com/axnsan12/drf-yasg"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="+validation"
17
18 RDEPEND=">=dev-python/coreapi-2.3.3[${PYTHON_USEDEP}]
19         >=dev-python/coreschema-0.0.4[${PYTHON_USEDEP}]
20         >=dev-python/ruamel-yaml-0.15.34[${PYTHON_USEDEP}]
21         >=dev-python/inflection-0.3.1[${PYTHON_USEDEP}]
22         >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
23         >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
24         >=dev-python/djangorestframework-3.8[${PYTHON_USEDEP}]
25         >=dev-python/django-1.11.7[${PYTHON_USEDEP}]
26         validation? ( >=dev-python/swagger-spec-validator-2.1.0[${PYTHON_USEDEP}] )"
27 DEPEND="${RDEPEND}
28 dev-python/setuptools[${PYTHON_USEDEP}]"