*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / dominate / dominate-2.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
10 HOMEPAGE="https://github.com/Knio/dominate"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )
22 "
23
24 python_test() {
25         pytest -vv || die "Tests failed with ${EPYTHON}"
26 }