*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / django-oauth-plus / django-oauth-plus-2.2.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7 # Testsuite written for py2 only, no indication given in source
8
9 inherit distutils-r1
10
11 DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
12 HOMEPAGE="https://pypi.org/project/django-oauth-plus/   http://code.welldev.org/django-oauth-plus/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         >=dev-python/django-1.3[${PYTHON_USEDEP}]
23         >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( ${RDEPEND}
26                 dev-python/mock[${PYTHON_USEDEP}] )"
27
28 python_test() {
29         PYTHONPATH=.:oauth_provider
30         if "${PYTHON}" oauth_provider/runtests/runtests.py; then
31                 einfo "Testsuite passed under ${EPYTHON}"
32         else
33                 die "Testsuite failed under ${EPYTHON}"
34         fi
35 }