*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / django-crispy-forms / django-crispy-forms-1.6.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Best way to have Django DRY forms"
11 HOMEPAGE="
12         https://pypi.org/project/django-crispy-forms/
13         https://github.com/maraujop/django-crispy-forms
14         https://django-crispy-forms.readthedocs.org/en/latest/"
15 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
16
17 SLOT="0"
18 LICENSE="MIT"
19 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
20 IUSE=""
21
22 RDEPEND=""
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25 "
26
27 # Seems to be incompletely packed
28 RESTRICT=test
29
30 python_test() {
31         DJANGO_SETTINGS_MODULE=crispy_forms.tests.test_settings py.test crispy_forms/tests || die
32 }