*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / deprecation / deprecation-2.0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A library to handle automated deprecations"
11 HOMEPAGE="https://deprecation.readthedocs.io/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
21 BDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/unittest2[${PYTHON_USEDEP}]
25                 ${RDEPEND}
26         )
27 "
28
29 python_test() {
30         "${EPYTHON}" -m unittest discover -v || die "tests failed with ${EPYTHON}"
31 }