*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / denonavr / denonavr-0.7.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python3_{6,7} )
7 PYTHON_REQ_USE="xml(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Automation Library for Denon AVR receivers"
12 HOMEPAGE="https://github.com/scarface-4711/denonavr"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
22 BDEPEND="
23         dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 ${RDEPEND}
26                 dev-python/pytest[${PYTHON_USEDEP}]
27                 dev-python/requests-mock[${PYTHON_USEDEP}]
28                 dev-python/testtools[${PYTHON_USEDEP}]
29         )
30 "
31
32 python_test() {
33         pytest -vv || die "tests failed with ${EPYTHON}"
34 }