*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / decorator / decorator-4.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Simplifies the usage of decorators for the average programmer"
10 HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
16
17 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18
19 DOCS=( CHANGES.md )
20
21 distutils_enable_tests setup.py