*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / curtsies / curtsies-0.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Curses-like terminal wrapper, with colored strings"
11 HOMEPAGE="https://github.com/thomasballinger/curtsies"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
22         dev-python/pyte[${PYTHON_USEDEP}]
23         >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         test? (
28                 dev-python/mock[${PYTHON_USEDEP}]
29                 dev-python/nose[${PYTHON_USEDEP}]
30                 dev-python/pyte[${PYTHON_USEDEP}]
31         )
32 "
33
34 python_test() {
35         nosetests --verbose tests || die
36 }