30ca026ab7e40e2ec9f59c25b0cb2f6365016ddf
[gentoo.git] / dev-python / csv23 / csv23-0.3.2.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
7 inherit distutils-r1
8
9 DESCRIPTION="Python 2/3 unicode CSV compatibility layer"
10 HOMEPAGE="
11         https://pypi.org/project/csv23/
12         https://github.com/xflr6/csv23/"
13 SRC_URI="https://github.com/xflr6/csv23/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
18
19 # note: upstream really uses mock at runtime
20 RDEPEND="
21         $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)"
22 BDEPEND="
23         test? (
24                 >=dev-python/pytest-4.6[${PYTHON_USEDEP}]
25                 dev-python/pytest-mock[${PYTHON_USEDEP}] )"
26
27 distutils_enable_tests pytest
28
29 src_prepare() {
30         sed -i -e '/--cov/d' setup.cfg || die
31         distutils-r1_src_prepare
32 }