*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / crcmod / crcmod-1.7-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python CRC Generator module"
11 HOMEPAGE="http://crcmod.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 arm x86"
17 IUSE=""
18
19 DOCS=( changelog test/examples.py )
20
21 python_test() {
22         "${PYTHON}" test/test_crcmod.py || die "Tests fail with ${EPYTHON}"
23 }