*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / configparser / configparser-3.3.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6 inherit distutils-r1
7
8 MY_PV=${PV%.*}r${PV##*.}
9 DESCRIPTION="Backport of Python-3 built-in configparser"
10 HOMEPAGE="https://pypi.org/project/configparser/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19
20 S=${WORKDIR}/${PN}-${MY_PV}