*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / colorama / colorama-0.3.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
11 HOMEPAGE="
12         https://pypi.org/project/colorama/
13         https://github.com/tartley/colorama"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
19 IUSE="examples"
20
21 python_install_all() {
22         use examples && local EXAMPLES=( demos/. )
23         distutils-r1_python_install_all
24 }