*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cloudlib / cloudlib-0.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Cloud middleware for in application use."
10 HOMEPAGE="https://github.com/cloudnull/cloudlib"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND=">=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}]
20                 >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]"
21
22 python_prepare() {
23         sed -i "s/required.append\(\'argparse\'\)/pass/g" setup.py || die
24 }