*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cli_helpers / cli_helpers-1.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7}} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python helpers for common CLI tasks"
10 HOMEPAGE="http://cli-helpers.rtfd.io/"
11 SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
21         >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
22         >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
23         >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
24         >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
25         dev-python/wcwidth[${PYTHON_USEDEP}]
26 "
27 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 ${RDEPEND}
30                 >=dev-python/mock-2[${PYTHON_USEDEP}]
31                 dev-python/pytest[${PYTHON_USEDEP}]
32         )"
33
34 python_test() {
35         pytest -vv || die "Tests fail with ${EPYTHON}"
36 }