*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cli_helpers / cli_helpers-1.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python helpers for common CLI tasks"
10
11 HOMEPAGE="http://cli-helpers.rtfd.io/"
12 SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18 RDEPEND="
19         >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
20         >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
21         >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
22 "