*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / cached-property / cached-property-1.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A cached-property for decorating methods in classes"
10 HOMEPAGE="https://github.com/pydanny/cached-property"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="test? (
20                 dev-python/pytest
21                 dev-python/freezegun
22                 )"
23 RDEPEND=""
24
25 src_install() {
26         distutils-r1_src_install
27         dodoc README.rst HISTORY.rst CONTRIBUTING.rst AUTHORS.rst
28 }
29
30 python_test() {
31         py.test || die
32 }