*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / billiard / billiard-3.5.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1 flag-o-matic
9
10 DESCRIPTION="Python multiprocessing fork"
11 HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="doc test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND=""
21 DEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
25                 >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
26         )"
27 # The usual req'd for tests
28 DISTUTILS_IN_SOURCE_BUILD=1
29
30 python_compile() {
31         if !  python_is_python3; then
32                 local CFLAGS=${CFLAGS}
33                 append-cflags -fno-strict-aliasing
34         fi
35         distutils-r1_python_compile
36 }
37
38 python_compile_all() {
39         use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
40 }
41
42 python_test() {
43         esetup.py test
44 }
45
46 python_install_all() {
47         use doc && local HTML_DOCS=( build/sphinx/html/. )
48         distutils-r1_python_install_all
49 }