*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / autopep8 / autopep8-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
12 HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
13 if [[ ${PV} == *9999* ]]; then
14         EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
15         inherit git-r3
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18         KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
19 fi
20
21 LICENSE="MIT"
22 SLOT="0"
23
24 RDEPEND=">=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]"
25 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
27
28 distutils_enable_tests setup.py