*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / async_generator / async_generator-1.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Making it easy to write async iterators in Python 3.5"
11 HOMEPAGE="https://github.com/python-trio/async_generator https://pypi.org/project/async_generator/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="|| ( MIT Apache-2.0 )"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
22
23 DOCS=( README.rst )
24
25 python_test() {
26         pytest -vv || die "tests failed under ${EPYTHON}"
27 }