*/*: Drop stable ia64 keywords
[gentoo.git] / dev-python / asn1crypto / asn1crypto-0.24.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
7 PYTHON_REQ_USE="threads(+)"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
12 HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
13 # pypi tarball does not have tests
14 SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND=""
23 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
24
25 python_test() {
26         esetup.py test
27 }