*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / argcomplete / argcomplete-1.10.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Bash tab completion for argparse"
11 HOMEPAGE="https://pypi.org/project/argcomplete/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 # pip is called as an external tool
21 BDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 app-shells/fish
25                 app-shells/tcsh
26                 dev-python/pexpect[${PYTHON_USEDEP}]
27                 dev-python/pip
28         )"
29
30 python_test() {
31         "${EPYTHON}" test/test.py -v || die
32 }