*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / apipkg / apipkg-1.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="namespace control and lazy-import mechanism"
10 HOMEPAGE="https://pypi.org/project/apipkg/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
16 IUSE="examples test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
20         dev-python/hgdistver[${PYTHON_USEDEP}]
21         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         py.test test_apipkg.py || die "Tests fail under ${EPYTHON}"
25 }
26
27 python_install_all() {
28         use examples && local EXAMPLES=( example/. )
29         distutils-r1_python_install_all
30 }