*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / aniso8601 / aniso8601-3.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A library for parsing ISO 8601 strings"
10 HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~x86"
16
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18 RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
19
20 python_test() {
21         "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
22 }