*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / algopy / algopy-0.5.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Taylor Arithmetic Computation and Algorithmic Differentiation"
11 HOMEPAGE="https://pypi.org/project/algopy/ https://pythonhosted.org/algopy/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/numpy[${PYTHON_USEDEP}]
22         sci-libs/scipy[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-python/nose[${PYTHON_USEDEP}] )
26 "
27 PATCHES=( "${FILESDIR}/${P}-fix-test-cast-ufunc.patch" )
28
29 python_test() {
30         ${EPYTHON} run_tests.py || die
31 }