*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / aiosmtpd / aiosmtpd-1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit distutils-r1
8
9 DESCRIPTION="asyncio based SMTP server"
10 HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
18 RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
19
20 src_prepare() {
21         rm -r examples || die
22         distutils-r1_python_prepare_all
23 }