*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / aioeventlet / aioeventlet-0.5.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="asyncio event loop scheduling callbacks in eventlet"
11 HOMEPAGE="https://pypi.org/project/aioeventlet/"
12 SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/eventlet[${PYTHON_USEDEP}]
22         $(python_gen_cond_dep '>=dev-python/trollius-0.3[${PYTHON_USEDEP}]' 'python2_7')"
23 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
24         test? (
25                 dev-python/aiotest[${PYTHON_USEDEP}]
26                 $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7') )"
27
28 python_test() {
29         # from tox.ini
30         "${PYTHON}" runtests.py -v || die "Tests fail with ${EPYTHON}"
31         "${PYTHON}" run_aiotest.py -v || die "Tests fail with ${EPYTHON}"
32 }