*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / ImageHash / ImageHash-4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Image Hashing library"
11 HOMEPAGE="https://github.com/JohannesBuchner/imagehash"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13 KEYWORDS="~amd64"
14
15 LICENSE="BSD-2"
16 SLOT="0"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/numpy[${PYTHON_USEDEP}]
22         dev-python/pillow[${PYTHON_USEDEP}]
23         dev-python/pywavelets[${PYTHON_USEDEP}]
24         dev-python/six[${PYTHON_USEDEP}]
25         sci-libs/scipy[${PYTHON_USEDEP}]"
26 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
27         test? ( ${RDEPEND} )"
28
29 python_test() {
30         esetup.py test
31 }