*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-php / PEAR-Net_SMTP / PEAR-Net_SMTP-1.8.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit php-pear-r2
7
8 MY_PN="${PN/PEAR-/}"
9 MY_P="${MY_PN}-${PV}"
10
11 DESCRIPTION="A PHP implementation of the SMTP protocol"
12 HOMEPAGE="https://pear.php.net/package/Net_SMTP"
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
16 IUSE="examples sasl"
17 DEPEND=""
18 RDEPEND="dev-lang/php:*
19         dev-php/PEAR-Net_Socket
20         dev-php/PEAR-PEAR
21         sasl? ( dev-php/PEAR-Auth_SASL )"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_install() {
26         DOCS=( docs/guide.txt )
27         use examples && HTML_DOCS=( examples )
28         php-pear-r2_src_install
29 }