*/*: Bump copyright on files touched this year
[gentoo.git] / dev-perl / gtk2-gladexml / gtk2-gladexml-1.7.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_NAME=Gtk2-GladeXML
7 DIST_AUTHOR=TSCH
8 DIST_VERSION=1.007
9 DIST_EXAMPLES=("examples/*")
10 inherit perl-module virtualx
11
12 DESCRIPTION="Create user interfaces directly from Glade XML files"
13 HOMEPAGE="http://gtk2-perl.sf.net/ https://metacpan.org/release/Gtk2-GladeXML"
14
15 SLOT="0"
16 LICENSE="LGPL-2"
17 KEYWORDS="~alpha amd64 ppc64 x86"
18 IUSE=""
19
20 RDEPEND="x11-libs/gtk+:2
21         gnome-base/libglade:2.0
22         >=dev-perl/glib-perl-1.020
23         >=dev-perl/Gtk2-1.012"
24 DEPEND="${RDEPEND}
25         >=dev-perl/ExtUtils-Depends-0.300
26         dev-perl/ExtUtils-PkgConfig"
27
28 src_test() {
29         virtx perl-module_src_test
30 }