*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / YAML / YAML-1.240.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=TINITA
7 DIST_VERSION=1.24
8 inherit perl-module
9
10 DESCRIPTION="YAML Ain't Markup Language (tm)"
11
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         virtual/perl-ExtUtils-MakeMaker
20         test? (
21                 >=virtual/perl-Test-Simple-0.880.0
22                 >=dev-perl/Test-YAML-1.50.0
23         )
24 "
25 PERL_RM_FILES=("t/author-pod-syntax.t")