*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / Sub-Uplevel / Sub-Uplevel-0.280.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DAGOLDEN
7 DIST_VERSION=0.2800
8 inherit perl-module
9
10 DESCRIPTION="Apparently run a function in a higher stack frame"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="virtual/perl-Carp"
18 DEPEND="${RDEPEND}
19         >=virtual/perl-ExtUtils-MakeMaker-6.170.0
20         test? (
21                 virtual/perl-Exporter
22                 virtual/perl-File-Spec
23                 virtual/perl-Test-Simple
24         )
25 "