*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / NetAddr-IP / NetAddr-IP-4.79.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MIKER
7 DIST_VERSION=4.079
8 inherit perl-module
9
10 DESCRIPTION="Manipulation and operations on IP addresses"
11
12 SLOT="0"
13 LICENSE="|| ( Artistic GPL-2 )"
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86"
15 IUSE="ipv6 test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="ipv6? ( dev-perl/Socket6 )"
19 DEPEND="${RDEPEND}
20         virtual/perl-ExtUtils-MakeMaker
21         test? ( virtual/perl-Test-Simple )
22 "
23 PATCHES=( "${FILESDIR}/${PN}-4.079-no-sleep.patch" )