*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / Module-Pluggable / Module-Pluggable-5.200.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=SIMONW
7 MODULE_VERSION=5.2
8 inherit perl-module
9
10 DESCRIPTION="Automatically give your module the ability to have plugins"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=virtual/perl-File-Spec-3
19         virtual/perl-if
20 "
21 DEPEND="${RDEPEND}
22         >=dev-perl/Module-Build-0.380.0
23         test? ( >=virtual/perl-Test-Simple-0.620.0 )
24 "
25
26 SRC_TEST="do parallel"