*/*: Bump copyright on files touched this year
[gentoo.git] / dev-perl / Math-BigInt-GMP / Math-BigInt-GMP-1.600.200.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=PJACKLAM
7 DIST_VERSION=1.6002
8 inherit perl-module
9
10 DESCRIPTION="Use the GMP library for Math::BigInt routines"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 hppa ppc sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=virtual/perl-Math-BigInt-1.999.801
19         >=virtual/perl-XSLoader-0.20.0
20         >=dev-libs/gmp-4.0.0:0
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? ( >=virtual/perl-Test-Simple-0.820.0 )
25 "
26 PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
27 src_test() {
28         perl_rm_files t/author-*.t t/00sig.t t/02pod.t t/03podcov.t
29         perl-module_src_test
30 }