*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / Gtk3 / Gtk3-0.34.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 DIST_AUTHOR=XAOC
6 DIST_VERSION=0.034
7 inherit perl-module virtualx
8
9 DESCRIPTION="Perl interface to the 3.x series of the gtk+ toolkit"
10 LICENSE="LGPL-2.1+"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         x11-libs/gtk+:3[introspection]
18         >=dev-perl/Cairo-GObject-1.0.0
19         virtual/perl-Carp
20         virtual/perl-Exporter
21         >=dev-perl/Glib-Object-Introspection-0.43.0
22
23 "
24 DEPEND="${RDEPEND}
25         >=virtual/perl-ExtUtils-MakeMaker-6.30
26         test? (
27                 >=virtual/perl-Test-Simple-0.960.0
28         )
29 "
30
31 PATCHES=(
32         # Fixed in next version, bug #683046
33         "${FILESDIR}"/${P}-gdk-pixbuf-test.patch
34 )
35
36 src_test() {
37         virtx perl-module_src_test
38 }