*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / File-Next / File-Next-1.160.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=PETDANCE
7 DIST_VERSION=1.16
8 inherit perl-module
9
10 DESCRIPTION="File::Next is an iterator-based module for finding files"
11
12 LICENSE="Artistic-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="virtual/perl-File-Spec"
19 DEPEND="${RDEPEND}
20         virtual/perl-ExtUtils-MakeMaker
21         test? ( virtual/perl-Test-Simple )
22 "
23
24 src_test() {
25         # Ugh, Upstream has tests that depend on tests ...
26         echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
27         echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
28         perl-module_src_test
29 }