f519f78fb259528d0543a723d48be5746dbbd20c
[gentoo.git] / dev-perl / File-BaseDir / File-BaseDir-0.30.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=PARDUS
7 MODULE_VERSION=0.03
8 inherit perl-module
9
10 DESCRIPTION="Use the Freedesktop.org base directory specification"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         dev-perl/Module-Build
20         test? (
21                 virtual/perl-Test-Simple
22         )"
23
24 SRC_TEST=do
25
26 src_test() {
27         perl_rm_files t/05_pod_cover.t t/04_pod_ok.t
28         perl-module_src_test
29 }